Resolving IBus Problems for IBus prior to 1.5.11

Published on Author craigzearfossLeave a comment

This is for if you’re on Ubuntu and when you start PhpStorm you get the warning IBus prior to 1.5.11 may cause input problems. See IDEA-78860 for details. These steps will fix the problem.

  1. Install the dependencies.
  2. sudo apt-get install libdconf-dev libnotify-dev intltool libgtk2.0-dev libgtk-3-dev libdbus-1-dev
    
  3. Download the ibus 1.5.11 source code.

    wget https://github.com/ibus/ibus/releases/download/1.5.11/ibus-1.5.11.tar.gz
    
  4. Extract the files and cd into the extracted folder.

    tar -xvf ibus-1.5.11.tar.gz
    cd ibus-1.5.11
    
  5. While in the ibus source folder, follow the instructions from step 1 to install ibus 1.5.11.

    ./configure --prefix=/usr --sysconfdir=/etc && make
    sudo make install
    
  6. Restart Intellij IDE or whichever jetbrain’s IDE that is in question.

Leave a Reply

Your email address will not be published. Required fields are marked *